2012年2月25日 星期六

LoNote升級到1.5了



東西放上網路,升級速度不知為什麼就快了起來。說來上次貼文時LoNote版本只有0.5的說……

好吧,雖然在另外幾個地方也稍微發文宣傳過了,不過自己的blog啥也沒寫,這還真有點說不太過去。

總之就來介紹一下。



首先是前言:
「LoNote是一款適合個人使用的筆記軟體。更進一步的說明請參看LoNote維基。」

介紹完畢(喂!)

好啦,可是每次都要說同樣的話真的很無聊啊。真要說些啥那也只能說:這是我現在在用的筆記軟體,而且我覺得她很好用,值得大家一試啦。而且也很萌

總之就讓我來和大家報告一下新版本多出哪些內容吧!

總之就是新東西

介面

讓LoNote更加美觀易用的小玩意兒。

  • 可以自定義筆記的CSS
  • 可以自定義編輯器字型
  • GUI設定介面
  • 多語系支援
  • 變更日期時間的顯示與插入格式

瀏覽

快速翻查舊有筆記時的方便功能。

  • 新增全筆記搜索功能
  • 新增書籤功能
  • 可以類似網頁瀏覽器那樣快速瀏覽上一頁與下一頁
  • 能夠滾頁到使用者指定的標題(Heading)
  • 上次編輯時的滾頁位置將被LoNote自動記憶
  • 自動記憶上次關閉程式時的視窗狀態,重新啟動後幾乎不用調整頁面配置

編輯

編寫筆記內容時所需要的道具。

  • 歷史記錄功能大升級,現在可輕易回復舊筆記頁的歷史紀錄
  • 插入圖片的格式允許使用者自定義
  • 圖片插入時提供預覽視窗
  • 提供可以移除筆記頁面上任何既有格式的按鈕。
  • 更好用的筆記附件管理
  • 更好用的超連結插入方式

匯出

資料永續保存與任意搬遷就靠這個了。

  • 匯出單頁筆記為HTML。
  • 匯出整本筆記為簡單的網站形式。
  • 可選擇自動在關閉筆記時進行全筆記本匯出。
  • 也可匯出特定頁面與其次級頁面為新的LoNote筆記本,配合匯入功能就能輕鬆地切分重組筆記本。

底層

平常感覺不到,但沒有考慮的話未來哪天說不定就會痛哭出來的東西。

  • 圖片插入功能不再一併插入一堆JS碼。(確保原始資料乾淨)
  • 失聯圖片自動回收的選項。(節約空間)
  • 插入圖片可設定自動壓縮。(節約空間)
  • 版本記錄採用差分編碼。(節約空間)


下載與安裝

請前往這裡下載,而詳細文件也在這裡:
LoNote專案網站
如果您使用源碼包執行的話,請確定您的系統中有 python3 與相應的 PyQt4 環境。詳細的配置方法與說明請參看「配置執行環境」那邊。

如果您還在用舊版的LoNote,建議您還是快更新吧。新版真的好用不少哦。

15 則留言:

  1. 請問近期內,還會不會瘋狂出更新呀?

    回覆刪除
  2. 近期內大概更新得差不多了吧?……畢竟堆積已久的點子大致已經都做出來了,剩下的都是些技術預研中發現暫時攻關不能的東西。
    不過各種小微調與bug修復方面,我用著用著發現不對勁,還是會陸續釋出的啦。

    回覆刪除
  3. 左側樹狀的資料:「拖曳結果會被LoNote永久保存下來,和筆記儲存在一起。」
    操作後發現,是可以移動到不同分支內,但不同資料的上下順序,手動上下移動,關閉筆記再重開後,順序又回復變更前的狀態。新增分頁時若先後資料弄錯,之後只能砍掉重練

    回覆刪除
  4. 我這邊測試最新版是可以的哦。不管是在ubuntu、archlinux還是windowsxp下執行時都沒問題。你有用最新版(1.6.9)的LoNote嗎?

    或是只在某種特定情況下發生(比方說只發生在拖拉到最上面或最下面時),所以我沒能測試出來?

    如果您會用終端機的話,請用終端機執行看看,看看會不會跳出什麼錯誤訊息之類的。貼給我看看,說不定我能找出原因。

    最後,如果您看得懂程式的話,這部份的程式碼是放在。
    main.py
    檔案的
    def _treeAfterDrop
    這行下面。(在1.6.9版中,是在第1363行)
    您也可以試著調整看看。

    無論如何請再留言,謝謝回報囉。

    回覆刪除
  5. 我看不懂……所以這個給你
    TypeError: expected 1 arguments, got 0
    TypeError: expected 1 arguments, got 0

    回覆刪除
  6. 謝謝您的回報,還請先確認一下版本號。

    確認版本的作法是:按「關於與說明」按鈕或,在跳出來的對話框中大大的「LoNote」字樣右下角有個小小的「Ver.X.X.X」這字樣,請確定那些XXX的數字是多少。

    建議您更新到最新版本(目前為1.6.9,請到這邊下載),說不定問題早就已經被解決了。就算您不願意更新,我也必須要知道您現在的版本才能幫您測試。才能進一步判斷出錯誤在哪裡。

    確認版本號是後面一切內容的基礎。

    您的錯誤訊息似乎只貼了一部份,應該還會有訊息指出錯誤出現在「哪個檔案」的「哪一行」裡。那些訊息的幫助很大,可以大大減少我的猜測範圍。

    目前這樣的錯誤訊息,我只能判斷應該是某個函式沒有給值。然而在1.6.9中,比較可疑的幾個地方,實際執行與肉眼觀察都完全沒有發現任何錯誤。

    順便一問,錯誤訊息是在什麼時候出現的?是在「拖拉移動」時出現的嗎?還是「放下時」出現的?還是在「關閉程式時」才出現的?還有您現在使用的是哪個平台(windows或其他)?這些訊息對解決問題多少也會有幫助的。

    不過一切的基礎還是在版本號上面,這個千萬千萬別忘了。(我還是強烈建議更新版本到最新版就是了,而且更新前建議手動備份原本的筆記資料)

    總之,謝謝你囉。

    回覆刪除
  7. 不好意思我疏忽了。
    我是用UBUNTU10.04,測試結果是,舊版0.4.2可以改變筆記的上下順序;但反而新版,無論是新創的筆記或是舊格式筆記,順序調整後再重開,內頁順序又跑掉。
    錯誤訊息出現在終端機開始執行lonote時,麻煩的地方就是只有出現那串文字,同樣內容不斷重複出現,直到關閉為止。

    回覆刪除
  8. 這是我草草錄下的影片。
    http://www.youtube.com/watch?v=RkBB5eXzWCQ

    剛好我有ubuntu 10.04,在下面執行最新版本的LoNote,調整順序沒有問題。
    看看是不是我誤解了你的問題,至少這樣是沒問題的。

    (我使用的pyqt版本是4.9版)

    回覆刪除
  9. 哈 在AUR里发现了呢
    挺好用的哦 界面好萌的最喜欢了 >_<
    准备作为以后学习笔记的使用咯
    感谢po主 ^_^

    回覆刪除
  10. 哇哈哈,喜歡就好。

    有 AUR 帳號的話有空順便投個票啦,都沒人投票害我一直懷疑到底有人在用沒有 囧rz。

    順便一提,今天上午剛好更新版本到 1.8.4,有需要就請享用吧。

    回覆刪除
  11. 新手發問(今日下載1.86版使用中)
    請教版主,為何使用"快速匯出(html)"卻無法產生html檔(連資料夾都沒有 整個沒反應)?
    "匯出(html網站)"也無效果;"匯出成新筆記簿"可正常運作。
    不知道是哪邊出了問題 @@

    Python 版本:3.2.2
    PyQt 版本:4.9.4
    作業系統:Win 7 64 bit

    謝謝版主回覆! :)

    回覆刪除
  12. 嗯唔,這還蠻奇怪的(搔頭……)。

    我重新進行了 windows 平台測試。確認 1.8.6 在 xp 下運作時,不管用哪種匯出方式,至少用「範本筆記」測試匯出功能是沒問題的。win7 64 bit 我手邊剛好沒有,晚點會再測試過。

    除此之外,html 與 html 網站匯出功能--是所有的筆記頁都無法匯出嗎?還是只是有某幾頁無法匯出呢。

    另外還請確認一下,企圖匯出的筆記頁,頁面名稱是否有用到任何可疑的特殊字元(不能成為檔名的那種字元,比方說./\#?之類的東西,空白也算),雖然程式中有濾掉不少可疑字元,但說不定濾得不夠徹底……

    謝謝囉!

    回覆刪除
  13. win 7 64 bit 測試終了,測試平台為 python 3.2.3 與 pyqt 4.9.4 (皆為當前最新)。

    老樣子,針對範本進行測試,發現匯出功能完全正常。

    嗚呃...既然這邊測不出問題,我一時也就無從處理起。總之還請您檢查一下咱上篇回復中提到的東西。另外,如果您有辦法提供終端機錯誤訊息的話(若從命令行執行就能看到),那也會很有幫助的,不過我不會指望這個啦。

    不管怎麼說,謝謝您辛苦回報問題囉。

    回覆刪除
  14. 感謝版主的熱心回覆,
    就在我將LoNote的位置路徑去除所有中文後,
    匯出功能恢復正常了!

    我測試了"快速匯出(html)","匯出(html網站)","匯出成新筆記簿",
    只剩下"匯出(html網站)"用ie開啟時會顯示錯誤(用firefox開啟則正常)這個可忽略的問題。

    回覆刪除
  15. 不客氣,請慢用哈。

    不過中文路徑嗎……怪哉,LoNote 應該不會在這種地方出問題呀。總之先記著,有空時再打掃一下看看。

    匯出成 html 網站方面,為了做旁邊那個(可折疊的)選單,在下運用了非常非常討巧的 css 程式碼,ie 要支援大概是沒戲的……偷偷說一句,其實 firefox 也支援得不完全,折疊時會有點瑕疵說,本人 css 技術不好,期待誰支援一下。雖然咱比較喜歡 Fx,但理想的顯示目前只能出現在 chrome 等 webkit 系瀏覽器上。

    回覆刪除

☆每日吐嘈,有益身心☆
…不過還是請手下留情別太狠啊。